티스토리 뷰

tesseract-ocrconfigure 하다보면 아래와 같은 오류가 출력되는 경우가 있다.


configure: error: Leptonica 1.74 or higher is required. Try to install libleptonica-dev package.


무려 Ubuntu 16.04 인데 말이다!! 우선 이미지 프로세싱에서 사용되는 leptonica 버전을 1.74 혹은 그 이상으로 올려야 한다는 의미인데, tesseract-ocr wiki 에서 아래와 같이 관련된 내용을 찾아 볼 수 있다.



but if you are using an oldish version of Linux, the Leptonica version may be too old, so you will need to build from source.

Tesseract versions and the minimum version of Leptonica required:

TesseractLeptonicaUbuntu
4.001.74.0Must build from source
3.041.71Ubuntu 16.04
3.031.70Ubuntu 14.04
3.021.69Ubuntu 12.04
3.011.67


내용을 확인 했으면 얌전히 leptonica를 다운로드 받아 컴파일 해야 한다. 다운로드는 아래 링크에서 받도록 한다.
http://www.leptonica.org/download.html


적절하게 1.74 이상의 버전을 다운로드 받았으면 컴파일을 진행해야 하는데 아래와 같은 과정으로 하면 되겠다.

$ ./configure; make; sudo make install


install시에 sudo 권한이 필요할 수 있으며 혹시 컴파일에 이상이 있는 듯 하면 make check를 실행하고 에러를 확인해 보면 된다. 이렇게 leptonica 설치가 끝났으면 다시 tesseract-ocrconfigure를 진행해보자. 정상적으로 에러 없이 동작하는 것을 확인할 수 있다.


oops@oops:tesseract$ ./configure --enable-debug

checking for g++... g++

checking whether the C++ compiler works... yes

checking for C++ compiler default output file name... a.out

...중략
config.status: executing libtool commands

Configuration is done.
You can now build and install tesseract by running:

$ make
$ sudo make install

You can not build training tools because of missing dependency.
Check configure output for details.

oops@oops:tesseract$ 


댓글
  • 프로필사진 BlogIcon Voyager Woo 좋은 포스트 감사합니다.

    근데 오타가 하나 있네요.. ./configure; make; make install

    세미 콜론으로 해야지 되는군요 ;;
    그리고 sudo make install 해야 되더라고요.

    정리하면 ./configure; make; sudo make install
    2017.06.04 01:25 신고
  • 프로필사진 BlogIcon Jaeyeon Baek 감사합니다. 수정되었습니다.

    실제 진행 내용 적어놓은 곳에는 제대로 써놨는데 말씀하신 부분에는 생각나는대로 타이핑해서 오타가 있었네요 :-)
    2017.06.05 07:59 신고
  • 프로필사진 비밀댓글입니다 2018.03.25 12:22
  • 프로필사진 BlogIcon Jaeyeon Baek libleptonica 컴파일하신 다음에 install 하면 library를 시스템 전체적으로 사용할 수 있는 상태라서 어디 위치에 두고 그런 개념이 아닙니다. tesseract 컴파일 할 때 알아서 참조됩니다. 2018.03.25 12:57 신고
댓글쓰기 폼